2-9one character from 2 (5010) to 9 (5710)
0-8one character from 0 (4810) to 8 (5610)
\1the text saved by group 1
\da Unicode decimal digit
-?optionally matches the literal - (4510 / 558 / 2D16)
2-9one character from 2 (5010) to 9 (5710)
Negative Lookahead(?!1(?=1)) 1the literal 1 (4910 / 618 / 3116)
1the literal 1 (4910 / 618 / 3116)
\da Unicode decimal digit
\da Unicode decimal digit
-?optionally matches the literal - (4510 / 558 / 2D16)
\d{4}a Unicode decimal digit, repeated exactly 4 times
g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string