const regex = /([0-9]+\.[0-9]+\.[0-9]+\.[0-9]+:[0-9]+\n)(?:^\1)+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9]+\\.[0-9]+\\.[0-9]+\\.[0-9]+:[0-9]+\\n)(?:^\\1)+', 'gm')
const str = `172.27.0.1:22
172.27.0.1:21
172.27.0.1:23
172.27.0.1:23
172.27.0.1:23
172.27.0.1:25
172.27.0.1:25
172.27.0.1:24
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);