$re = '/\[\[https?:\/\/(*SKIP)(*FAIL)|\[\[\K[^][|]+/m';
$str = '[[my_page]]
[[my_other_page|this is my other page]]
[[http://your_page|this is your page]]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);