using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^74891.+$";
string input = @"Test 123
1233. 2334
74891.32432 423423 4234234234 234234
abc 123456767.343. 434
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}