const regex = /^74891.+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^74891.+$', 'gm')
const str = `Test 123
1233. 2334
74891.32432 423423 4234234234 234234
abc 123456767.343. 434
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}