const regex = /^((\+?\d{1,4})?[-.\s]?\(?(\d{1,3})?\)?[-.\s]?(\d{1,4})[-.\s]?(\d{1,4})[-.\s]?(\d{1,9}))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((\\+?\\d{1,4})?[-.\\s]?\\(?(\\d{1,3})?\\)?[-.\\s]?(\\d{1,4})[-.\\s]?(\\d{1,4})[-.\\s]?(\\d{1,9}))', 'gm')
const str = `+49 172 7470791
+49 621 60-6641516
+49 621 60-41516
8-1-6641516
+7(927)296-96-08
61 41516
6641516
41516
`;
const subst = `$2$3$4$5$6`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);