$re = '/(url|href|src)\s*[=\(]\s*([\'"][^\'"]+[\'"]|[^\s\)]+)(?=(\/?>|\s*\)))?/m';
$str = 'url(wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff)
url("wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff")
url(\'wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\')
url ( wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff )
url ( "wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff" )
url ( \'wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\' )
url(wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff)
url("wp-con)tent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff")
url(\'wp-cont)ent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\')
url ( wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff )
url ( "wp-con)tent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff" )
url ( \'wp-cont)ent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\' )
-------
<link rel=\'stylesheet\' id=\'base-css\' href=\'wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2\' type=\'text/css\' media=\'all\' />
<link rel=\'stylesheet\' id=\'base-css\' href="wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2" type=\'text/css\' media=\'all\' />
<link rel=\'stylesheet\' id=\'base-css\' href=wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2 type=\'text/css\' media=\'all\' />
<link rel=\'stylesheet\' id=\'base-css\' href = \'wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2\' type=\'text/css\' media=\'all\' />
<link rel=\'stylesheet\' id=\'base-css\' href = "wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2" type=\'text/css\' media=\'all\' />
<link rel=\'stylesheet\' id=\'base-css\' href = wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2 type=\'text/css\' media=\'all\' />
<link rel=\'stylesheet\' id=\'base-css\' href=\'wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2\'/>
<link rel=\'stylesheet\' id=\'base-css\' href="wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2"/>
<link rel=\'stylesheet\' id=\'base-css\' href=wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2/>
<link rel=\'stylesheet\' id=\'base-css\' href = \'wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2\'/>
<link rel=\'stylesheet\' id=\'base-css\' href = "wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2"/>
<link rel=\'stylesheet\' id=\'base-css\' href = wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2 />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);