# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\w)(?:\Q+end\E|\Qsomething-\E)(?!\w)//g;t' <<< "oh end m+end something-strange oh something +end something- here"