use strict;
my $str = 'oh end m+end something-strange oh something +end something- here';
my $regex = qr/(?<!\w)(?:\Q+end\E|\Qsomething-\E)(?!\w)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";