re = /(?<!\w)(?:\Q+end\E|\Qsomething-\E)(?!\w)/
str = 'oh end m+end something-strange oh something +end something- here'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result