import Foundation
let pattern = #"(?<!\w)(?:\Q+end\E|\Qsomething-\E)(?!\w)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"oh end m+end something-strange oh something +end something- here"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)