#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)shop\.xerox\.com\/(?=.*?\d)(?=.*?[a-zA-Z])[a-zA-Z\d]+\-?.+"
Local $sString = "https://www.shop.xerox.com/" & @CRLF & _
"https://www.shop.xerox.com/products/" & @CRLF & _
"https://www.shop.xerox.com/products/printers" & @CRLF & _
"https://www.shop.xerox.com/006r04422" & @CRLF & _
"https://www.shop.xerox.com/" & @CRLF & _
"https://www.shop.xerox.com/xerox-c230"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")