const regex = /shop\.xerox\.com\/(?=.*?\d)(?=.*?[a-zA-Z])[a-zA-Z\d]+\-?.+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('shop\\.xerox\\.com\\\/(?=.*?\\d)(?=.*?[a-zA-Z])[a-zA-Z\\d]+\\-?.+', 'gm')
const str = `https://www.shop.xerox.com/
https://www.shop.xerox.com/products/
https://www.shop.xerox.com/products/printers
https://www.shop.xerox.com/006r04422
https://www.shop.xerox.com/
https://www.shop.xerox.com/xerox-c230`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}