re = /shop\.xerox\.com\/(?=.*?\d)(?=.*?[a-zA-Z])[a-zA-Z\d]+\-?.+/m
str = 'https://www.shop.xerox.com/
https://www.shop.xerox.com/products/
https://www.shop.xerox.com/products/printers
https://www.shop.xerox.com/006r04422
https://www.shop.xerox.com/
https://www.shop.xerox.com/xerox-c230'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end