const regex = /(?<=\<input.*\>)\n/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\<input.*\\>)\\n', 'gm')
const str = ` <td class="examplelink">
<input name="chkexpert[]" type="checkbox" value="Java" checked="checked">
Java
<input name="chkexpert[]2" type="checkbox" value="PHP" checked="checked">
PHP
<input name="chkexpert[]2" type="checkbox" value="ASP" checked="checked">
ASP
<input type="checkbox" name="chkexpert[]2" value=".NET">
.NET
<input name="chkexpert[]2" type="checkbox" value="JavaScript">
Java Script</td>
</tr>
<tr>
<td>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}