Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
"
(\+?[\d]{1,3}([-]{0,2}|[\s]+)?)?\(?(\d{3})\)?([-]{0,2}|[\s])?(\d{3})([-]{0,2}|[\s])?(\d{4})(\s?(([E|e]xt[:|.|]?)|x|X)(\s?\d+))?
"
gm
Input 1
1
New
1645162589000 1-718-444-1122 718-444-1122 (718)-444-1122 17184441122 7184441122 718.444.1122 1718.444.1122 1-123-456-7890 1 123-456-7890 1 (123) 456-7890 1 123 456 7890 1.123.456.7890 +91 (123) 456-7890 18005551234 1 800 555 1234 +1 800 555-1234 +86 800 555 1234 1-800-555-1234 1 (800) 555-1234 (800)555-1234 (800) 555-1234 (800)5551234 800-555-1234 800.555.1234 18001234567 1 800 123 4567 1-800-123-4567 +18001234567 +1 800 123 4567 +1 (800) 123 4567 1(800)1234567 +1800 1234567 1.8001234567 1.800.123.4567 +1 (800) 123-4567 18001234567 1 800 123 4567 +1 800 123-4567 +86 800 123 4567 1-800-123-4567 1 (800) 123-4567 (800)123-4567 (800) 123-4567 (800)1234567 800-123-4567 800.123.4567 1231231231 123-1231231 123123-1231 123-123 1231 123 123-1231 123-123-1231 (123)123-1231 (123)123 1231 (123) 123-1231 (123) 123 1231 +99 1234567890 +991234567890 (555) 444-6789 555-444-6789 555.444.6789 555 444 6789 18005551234 1 800 555 1234 +1 800 555-1234 +86 800 555 1234 1-800-555-1234 1.800.555.1234 +1.800.555.1234 1 (800) 555-1234 (800)555-1234 (800) 555-1234 (800)5551234 800-555-1234 800.555.1234 (003) 555-1212 (103) 555-1212 (911) 555-1212 18005551234 1 800 555 1234 +86 800-555-1234 1 (800) 555-1234 1234567890 Ext: 1123123 1234567890Ext: 1123123 1234567890 Ext:1123123