#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[.*\s\S*"
Local $sString = "DeletedFiles: 2" & @CRLF & _
"DeletedFolders: 0" & @CRLF & _
"ModifiedFiles: 9" & @CRLF & _
"ExaminedFiles: 26676" & @CRLF & _
"OpenedFiles: 12" & @CRLF & _
"AddedFiles: 3" & @CRLF & _
"SizeOfModifiedFiles: 83376840" & @CRLF & _
"SizeOfAddedFiles: 1418892" & @CRLF & _
"SizeOfExaminedFiles: 14088761790" & @CRLF & _
"SizeOfOpenedFiles: 84801922" & @CRLF & _
"NotProcessedFiles: 0" & @CRLF & _
"AddedFolders: 0" & @CRLF & _
"TooLargeFiles: 0" & @CRLF & _
"FilesWithError: 0" & @CRLF & _
"ModifiedFolders: 0" & @CRLF & _
"ModifiedSymlinks: 0" & @CRLF & _
"AddedSymlinks: 0" & @CRLF & _
"DeletedSymlinks: 0" & @CRLF & _
"PartialBackup: False" & @CRLF & _
"Dryrun: False" & @CRLF & _
"MainOperation: Backup" & @CRLF & _
"ParsedResult: Success" & @CRLF & _
"EndTime: 15. 4. 2018 17:41:38 (1523806898)" & @CRLF & _
"BeginTime: 15. 4. 2018 17:39:10 (1523806750)" & @CRLF & _
"Duration: 00:02:27.4906343" & @CRLF & _
"Messages: [" & @CRLF & _
" 2018-04-15 17:39:10 +02 - [Information-Duplicati.Library.Main.Controller-StartingOperation]: The operation Backup has started," & @CRLF & _
" 2018-04-15 17:39:20 +02 - [Information-Duplicati.Library.Main.BasicResults-BackendEvent]: Backend event: List - Started: ()," & @CRLF & _
" 2018-04-15 17:39:21 +02 - [Information-Duplicati.Library.Main.BasicResults-BackendEvent]: Backend event: List - Completed: (726 bytes)," & @CRLF & _
" 2018-04-15 17:40:31 +02 - [Information-Duplicati.Library.Main.BasicResults-BackendEvent]: Backend event: Put - Started: duplicati-b11e3ae12fdc54bebac1b9cd715de2280.dblock.zip.aes (1.27 MB)," & @CRLF & _
" 2018-04-15 17:40:32 +02 - [Information-Duplicati.Library.Main.BasicResults-BackendEvent]: Backend event: Put - Completed: duplicati-b11e3ae12fdc54bebac1b9cd715de2280.dblock.zip.aes (1.27 MB)," & @CRLF & _
" 2018-04-15 17:40:32 +02 - [Information-Duplicati.Library.Main.BasicResults-BackendEvent]: Backend event: Put - Started: duplicati-i8875b05b15ae41baab0188a3845d5b3d.dindex.zip.aes (29.92 KB)," & @CRLF & _
" 2018-04-15 17:40:32 +02 - [Information-Duplicati.Library.Main.BasicResults-BackendEvent]: Backend event: Put - Completed: duplicati-i8875b05b15ae41baab0188a3845d5b3d.dindex.zip.aes (29.92 KB)," & @CRLF & _
" 2018-04-15 17:40:33 +02 - [Information-Duplicati.Library.Main.BasicResults-BackendEvent]: Backend event: Put - Started: duplicati-20180415T153910Z.dlist.zip.aes (2.41 MB)," & @CRLF & _
" 2018-04-15 17:40:35 +02 - [Information-Duplicati.Library.Main.BasicResults-BackendEvent]: Backend event: Put - Completed: duplicati-20180415T153910Z.dlist.zip.aes (2.41 MB)," & @CRLF & _
" 2018-04-15 17:40:35 +02 - [Information-Duplicati.Library.Main.Operation.DeleteHandler:RetentionPolicy-StartCheck]: Start checking if backups can be removed," & @CRLF & _
"..." & @CRLF & _
"]" & @CRLF & _
"Warnings: []" & @CRLF & _
"Errors: []" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")