re = /\d{1,2}\/\d{1,2}\/\d{1,4}\s+R[$]((?:\d+\.)?\d+\,\d+)/m
str = ' 18/01/2021 R$37.187,30'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end