$re = '~^(?!-0$)-?[0-9][0-9]{0,2}$~m';
$str = '-999
0
1
2
3
9
99
-99
-100
999
-0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);