import re
regex = re.compile(r"<a .*?href=(['\"]?).*?\/?download.aspx\?myid=\{?([0-9a-f]{8}-?[0-9a-f]{4}-?[0-9a-f]{4}-?[0-9a-f]{4}-?[0-9a-f]{12})\}?\1.*?>(.*?)<\/a>", flags=re.MULTILINE | re.IGNORECASE)
test_str = "<a clicktracking=off href=\"https://www.test.com/1.pdf\">test</a><br />Test<br />Test</div><br><div> </div><br><div><a clicktracking=off href=\"download.aspx?myID=11111111-2222-3333-4444-555555555555\">Teet.docx</a></div>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")