package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\[url\]https?:\/\/twitter\.com\/(?:\#!\/)?(\w+)\/status(es)?\/(\d+)(\?s=\d+)?\[\/url\]`)
var str = `[url]https://twitter.com/capitalweather/status/1255596050162860037[/url]
[url]https://twitter.com/capitalweather/status/1255596050162860037?s=12[/url]
https://twitter.com/MacRumors/status/1255253753155989507?s=20
twitter.com/ksldc
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}