const regex = /^-((?:(?:(?!{.*?})[^-\n]|{.*?})|(?:(?:(?!{.*?})[^-\n]|{.*?})*?-){2})*)-/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^-((?:(?:(?!{.*?})[^-\\n]|{.*?})|(?:(?:(?!{.*?})[^-\\n]|{.*?})*?-){2})*)-', 'gm')
const str = `-Hello everybody!- I'm here!
-This {stuff} matches- here.
-No match found {here-}.
-But this last {hyphen-} works-
-some -inner hyphens- inside- here.
-some --inner hyphens- but the odd one outside -.
-inner hyphens -inside- {braces-} -are- still ignored in this count- as usual-
-Hyphens both before- and after {the-braces} must be counted-
-This is {fine-
-And so is this- here}
-----`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}