$re = '/^-((?:(?:(?!{.*?})[^-\n]|{.*?})|(?:(?:(?!{.*?})[^-\n]|{.*?})*?-){2})*)-/m';
$str = '-Hello everybody!- I\'m here!
-This {stuff} matches- here.
-No match found {here-}.
-But this last {hyphen-} works-
-some -inner hyphens- inside- here.
-some --inner hyphens- but the odd one outside -.
-inner hyphens -inside- {braces-} -are- still ignored in this count- as usual-
-Hyphens both before- and after {the-braces} must be counted-
-This is {fine-
-And so is this- here}
-----';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);