using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"part(0*[2-9][0-9]*|0*1[0-9]+)\.rar";
string input = @"S01.rar
S23.part1.rar
s4.part01.rar
Movie.rar
Youtube Movie.part1.rar
123Mov Ddaa.part01.rar
123Mov Ddaa.part001.rar
S01.part11.rar
S01.part010.rar
S01.part100.rar
S01.part02.rar
S2.part4.rar
Movie.part3.rar
Youtube Movie.part08.rar
123Mov Ddaa.part002.rar";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}