// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[sS]ee, e\.g\.,.*(\(D\.C\. Cir\.)?.*(\(11th Cir\.)?.*(\(10th Cir\.)?.*(\(9th Cir\.)?.*(\(8th Cir\.)?.*(\(7th Cir\.)?.*(\(6th Cir\.)?.*(\(5th Cir\.)?.*(\(4th Cir\.)?.*(\(3d Cir\.)?.*(\(2d Cir\.)?.*(\(1st Cir\.)?.*\.").unwrap();
let string = "See, e.g., Smith v. U.S. (1st Cir. 2012); U.S. v. Sara (5th Cir. 2017).
See, e.g., Jefferson v. U.S. (10th Cir. 2012); U.S. v. Coolidge (D.C. Cir. 2017).
See, e.g., Lincoln v. Jones (3d Cir. 2012); U.S. v. Roosevelt (9th Cir. 2017).
See, e.g., Smith v. U.S. (5th Cir. 2012); U.S. v. Sara (1st Cir. 2017).
See, e.g., Jefferson v. U.S. (D.C. Cir. 2012); U.S. v. Coolidge (10th Cir. 2017).
See, e.g., Lincoln v. Jones (9th Cir. 2012); U.S. v. Roosevelt (3d Cir. 2017).";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}