$re = '/([^ ]+)/m';
$str = 'Ячейка1 Ячейка2 Ячейка3
заменить на
$1$2$3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);