using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"MyValue\d{5,6}";
string input = @"MyValue12345 blah blah MyValue123456 blah MyValue222221";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}