$re = '/MyValue\d{5,6}/mi';
$str = 'MyValue12345 blah blah MyValue123456 blah MyValue222221';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);