#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<io_device_name>[a-z|0-9]+)+\s+(?P<io_read_req_per_sec>\d+\.\d+)+\s+(?P<io_write_req_per_sec>\d+\.\d+)+\s+(?P<io_read_kb_per_sec>\d+\.\d+)+\s+(?P<io_write_kb_per_sec>\d+\.\d+)+\s+(?P<io_req_avg_wait_millisec>\d+\.\d+)+\s+(?P<io_req_avg_service_millisec>\d+\.\d+)+\s+(?P<io_bandwidth_utilization_percent>\d+\.\d+)"
Local $sString = "Device rReq_PS wReq_PS rKB_PS wKB_PS avgWaitMillis avgSvcMillis bandwUtilPct" & @CRLF & _
"loop0 0.00 0.00 0.00 0.00 0.00 0.00 0.00" & @CRLF & _
"loop1 0.00 0.00 0.00 0.00 0.00 0.00 0.00" & @CRLF & _
"loop2 0.00 0.00 0.00 0.00 0.00 0.00 0.00" & @CRLF & _
"loop3 0.00 0.00 0.00 0.00 0.00 0.00 0.00" & @CRLF & _
"loop4 0.00 0.00 0.00 0.00 0.00 0.00 0.00" & @CRLF & _
"nvme0n1 0.00 15.00 0.00 60.00 0.80 0.53 0.80" & @CRLF & _
"Device rReq_PS wReq_PS rKB_PS wKB_PS avgWaitMillis avgSvcMillis bandwUtilPct" & @CRLF & _
"loop0 0.00 0.00 0.00 0.00 0.00 0.00 0.00" & @CRLF & _
"loop1 0.00 0.00 0.00 0.00 0.00 0.00 0.00" & @CRLF & _
"loop2 0.00 0.00 0.00 0.00 0.00 0.00 0.00" & @CRLF & _
"loop3 0.00 0.00 0.00 0.00 0.00 0.00 0.00" & @CRLF & _
"loop4 0.00 0.00 0.00 0.00 0.00 0.00 0.00" & @CRLF & _
"nvme0n1 10.00 15.00 445.00 60.00 41.80 15.53 100.80"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")