using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<io_device_name>[a-z|0-9]+)+\s+(?P<io_read_req_per_sec>\d+\.\d+)+\s+(?P<io_write_req_per_sec>\d+\.\d+)+\s+(?P<io_read_kb_per_sec>\d+\.\d+)+\s+(?P<io_write_kb_per_sec>\d+\.\d+)+\s+(?P<io_req_avg_wait_millisec>\d+\.\d+)+\s+(?P<io_req_avg_service_millisec>\d+\.\d+)+\s+(?P<io_bandwidth_utilization_percent>\d+\.\d+)";
string input = @"Device rReq_PS wReq_PS rKB_PS wKB_PS avgWaitMillis avgSvcMillis bandwUtilPct
loop0 0.00 0.00 0.00 0.00 0.00 0.00 0.00
loop1 0.00 0.00 0.00 0.00 0.00 0.00 0.00
loop2 0.00 0.00 0.00 0.00 0.00 0.00 0.00
loop3 0.00 0.00 0.00 0.00 0.00 0.00 0.00
loop4 0.00 0.00 0.00 0.00 0.00 0.00 0.00
nvme0n1 0.00 15.00 0.00 60.00 0.80 0.53 0.80
Device rReq_PS wReq_PS rKB_PS wKB_PS avgWaitMillis avgSvcMillis bandwUtilPct
loop0 0.00 0.00 0.00 0.00 0.00 0.00 0.00
loop1 0.00 0.00 0.00 0.00 0.00 0.00 0.00
loop2 0.00 0.00 0.00 0.00 0.00 0.00 0.00
loop3 0.00 0.00 0.00 0.00 0.00 0.00 0.00
loop4 0.00 0.00 0.00 0.00 0.00 0.00 0.00
nvme0n1 10.00 15.00 445.00 60.00 41.80 15.53 100.80";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}