import re
regex = re.compile(r"^(?P<io_device_name>[a-z|0-9]+)+\s+(?P<io_read_req_per_sec>\d+\.\d+)+\s+(?P<io_write_req_per_sec>\d+\.\d+)+\s+(?P<io_read_kb_per_sec>\d+\.\d+)+\s+(?P<io_write_kb_per_sec>\d+\.\d+)+\s+(?P<io_req_avg_wait_millisec>\d+\.\d+)+\s+(?P<io_req_avg_service_millisec>\d+\.\d+)+\s+(?P<io_bandwidth_utilization_percent>\d+\.\d+)", flags=re.MULTILINE)
test_str = ("Device rReq_PS wReq_PS rKB_PS wKB_PS avgWaitMillis avgSvcMillis bandwUtilPct\n"
"loop0 0.00 0.00 0.00 0.00 0.00 0.00 0.00\n"
"loop1 0.00 0.00 0.00 0.00 0.00 0.00 0.00\n"
"loop2 0.00 0.00 0.00 0.00 0.00 0.00 0.00\n"
"loop3 0.00 0.00 0.00 0.00 0.00 0.00 0.00\n"
"loop4 0.00 0.00 0.00 0.00 0.00 0.00 0.00\n"
"nvme0n1 0.00 15.00 0.00 60.00 0.80 0.53 0.80\n"
"Device rReq_PS wReq_PS rKB_PS wKB_PS avgWaitMillis avgSvcMillis bandwUtilPct\n"
"loop0 0.00 0.00 0.00 0.00 0.00 0.00 0.00\n"
"loop1 0.00 0.00 0.00 0.00 0.00 0.00 0.00\n"
"loop2 0.00 0.00 0.00 0.00 0.00 0.00 0.00\n"
"loop3 0.00 0.00 0.00 0.00 0.00 0.00 0.00\n"
"loop4 0.00 0.00 0.00 0.00 0.00 0.00 0.00\n"
"nvme0n1 10.00 15.00 445.00 60.00 41.80 15.53 100.80")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")