re = /(?=.*[0-9])(?=.*[a-z])(?=.*[A-Z])[0-9a-zA-Z !"#$%&'()*+,-.\/:;<=>?@\[\\\]^_`{|}~]{8,255}/
str = 'Abcdefg !"#$%&\'()*+,-./:;<=>?@[\\]^_`{|}~1!hi'
# Print the match result
str.match(re) do |match|
puts match.to_s
end