use strict;
my $str = '"0x00000000","What do you want to eat? fish, meat or\\n eggs?",""
"0x00030002","What do you want to eat?",""
0x00030002,What do you want to eat?,
"0x00030002","What do you, want to eat?",""
0x00030002,What do "you want" to eat?,
"0x00030002,What do you want to eat?,",?,
"0x00030002","What do you want to eat?,"
0x00030002 ,What do you want to eat?",
Note \\n is included in [^"\\n] merely to test the regex against multiple strings.';
my $regex = qr/(?<=,")[^"\n]*(?=",)|(?<=,)(?!")[^,\n]*(?<!")(?=,)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}