const regex = /[^\/]*\/\/[^\/]*\/rest\/([^\/]*).*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\\/]*\\\/\\\/[^\\\/]*\\\/rest\\\/([^\\\/]*).*', 'g')
const str = `http://jira.websentinel.net/rest/api/2/search
http://jira.websentinel.net/rest/agile/1.0/board/1/sprint`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}