$re = '/[^\/]*\/\/[^\/]*\/rest\/([^\/]*).*/';
$str = 'http://jira.websentinel.net/rest/api/2/search
http://jira.websentinel.net/rest/agile/1.0/board/1/sprint';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);