#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)B[lr]?il?aul?[td]"
Local $sString = "Healer's Briault renamed to Healer's Bliaut" & @CRLF & _
"Cleric's Briault renamed to Cleric's Bliaut" & @CRLF & _
"Hlr. Briault +1 renamed to Hlr. Bliaut +1" & @CRLF & _
"Clr. Briault +1 renamed to Clr. Bliaut +1" & @CRLF & _
"Orison Bliaud renamed to Orison Bliaut" & @CRLF & _
"Orison Bliaud +1 renamed to Orison Bliaut +1" & @CRLF & _
"Orison Bliaud +2 renamed to Orison Bliaut +2" & @CRLF & _
"Clr. Briault +2 renamed to Clr. Bliaut +2" & @CRLF & _
"Ebers Bliaud renamed to Ebers Bliaut" & @CRLF & _
"Ebers Bliaud +1 renamed to Ebers Bliaut +1" & @CRLF & _
"Gende. Bilaut +1 renamed to Gende. Bliaut +1" & @CRLF & _
"Piety Briault renamed to Piety Bliaut" & @CRLF & _
"Piety Briault +1 renamed to Piety Bliaut +1" & @CRLF & _
"Piety Briault +2 renamed to Piety Bliaut +2" & @CRLF & _
"Piety Briault +3 renamed to Piety Bliaut +3" & @CRLF & _
"Theo. Briault renamed to Theo. Bliaut" & @CRLF & _
"Theo. Briault +1 renamed to Theo. Bliaut +1" & @CRLF & _
"Theo. Briault +2 renamed to Theo. Bliaut +2" & @CRLF & _
"Theo. Briault +3 renamed to Theo. Bliaut +3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")