use strict;
my $str = 'Healer\'s Briault renamed to Healer\'s Bliaut
Cleric\'s Briault renamed to Cleric\'s Bliaut
Hlr. Briault +1 renamed to Hlr. Bliaut +1
Clr. Briault +1 renamed to Clr. Bliaut +1
Orison Bliaud renamed to Orison Bliaut
Orison Bliaud +1 renamed to Orison Bliaut +1
Orison Bliaud +2 renamed to Orison Bliaut +2
Clr. Briault +2 renamed to Clr. Bliaut +2
Ebers Bliaud renamed to Ebers Bliaut
Ebers Bliaud +1 renamed to Ebers Bliaut +1
Gende. Bilaut +1 renamed to Gende. Bliaut +1
Piety Briault renamed to Piety Bliaut
Piety Briault +1 renamed to Piety Bliaut +1
Piety Briault +2 renamed to Piety Bliaut +2
Piety Briault +3 renamed to Piety Bliaut +3
Theo. Briault renamed to Theo. Bliaut
Theo. Briault +1 renamed to Theo. Bliaut +1
Theo. Briault +2 renamed to Theo. Bliaut +2
Theo. Briault +3 renamed to Theo. Bliaut +3';
my $regex = qr/B[lr]?il?aul?[td]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}