$re = '/ciao\/(.*\/)+?qu(.*?)nt(.*?)\.txt/m';
$str = 'ciao/a/tutt3i/quantiuosad.txt
ciao/a/quanti.txt
ciao/a/quantia.txt
quanti.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);