$re = '`^000.*$`m';
$str = '11111
00010
10001
10101
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);