package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<[a-zA-Z]:BusinessId>(?P<BusinessId>[0-9]*?)`)
var str = `<Root><Node><a:BusinessId>88</a:BusinessId></Node><Node><a:BusinessId>88</a:BusinessId></Node><Node><a:BusinessId>88</a:BusinessId></Node><Node><a:BusinessId>88</a:BusinessId></Node></Root>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}