re = /<[a-zA-Z]:BusinessId>(?P<BusinessId>[0-9]*?)/m
str = '<Root><Node><a:BusinessId>88</a:BusinessId></Node><Node><a:BusinessId>88</a:BusinessId></Node><Node><a:BusinessId>88</a:BusinessId></Node><Node><a:BusinessId>88</a:BusinessId></Node></Root>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end