package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(1\s?)?(\d{6})?(\(\d{3}\)|\d{3})[\s\-]?\d{3}[\s\-]?\d{4}$`)
var str = `5555555555`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}