$re = '/ABC(?<Name>.+?)XYZ/m';
$str = 'ABCDEFGHIJKLMNOPQRSTUVWXYZ';
$subst = "\g<Name>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;