$re = '/\b(\d+)\s*-\s*(?=\d)/m';
$str = '1 - 8 - 9
90 - older
10 - 89 - 90';
$subst = "$1-$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;