$re = '/#{3}(?P<town>.*?)(@{3}\n.*?)(&{3}(?P<person>.*?)(\^{3}\n))+?/ms';
$str = 'STARTOFTEXT
&&&Aragorn^^^
###The Shire@@@
&&&Frodo^^^
&&&Bilbo^^^
&&&Pippin^^^
###Gondor@@@
&&&Faramir^^^
&&&Boramir^^^
ENDOFTEXT';
$subst = "\g<person> is from \g<town>\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;