#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([A-Z]{1}\d{2}[A-Z]{1}$|\d{1}\d{2}[A-Z]{1}$|\d{7}[A-Z]{1}$|\d{1,2}\-\d{1,2}$)"
Local $sString = "FPN 0085110A" & @CRLF & _
"FPN 0091010Y" & @CRLF & _
"FPN 0095100J" & @CRLF & _
"FPN 0095130B" & @CRLF & _
"FPN 0097660F" & @CRLF & _
"AGEBAND10YR 0-9" & @CRLF & _
"AGEBAND10YR 10-19" & @CRLF & _
"AGEBAND10YR 20-29" & @CRLF & _
"AGEBAND10YR 30-39" & @CRLF & _
"AGEBAND10YR 40-49" & @CRLF & _
"AGEBAND10YR 50-59" & @CRLF & _
"AGEBAND10YR 60-69" & @CRLF & _
"AGEBAND10YR 70-79" & @CRLF & _
"DRGGrpV6X 801A" & @CRLF & _
"DRGGrpV6X 801B" & @CRLF & _
"DRGGrpV6X A09B" & @CRLF & _
"DRGGrpV6X A11A" & @CRLF & _
"DRGGrpV6X A11B" & @CRLF & _
"DRGGrpV6X A12Z"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")