use strict;
my $str = 'FPN 0085110A
FPN 0091010Y
FPN 0095100J
FPN 0095130B
FPN 0097660F
AGEBAND10YR 0-9
AGEBAND10YR 10-19
AGEBAND10YR 20-29
AGEBAND10YR 30-39
AGEBAND10YR 40-49
AGEBAND10YR 50-59
AGEBAND10YR 60-69
AGEBAND10YR 70-79
DRGGrpV6X 801A
DRGGrpV6X 801B
DRGGrpV6X A09B
DRGGrpV6X A11A
DRGGrpV6X A11B
DRGGrpV6X A12Z';
my $regex = qr/([A-Z]{1}\d{2}[A-Z]{1}$|\d{1}\d{2}[A-Z]{1}$|\d{7}[A-Z]{1}$|\d{1,2}\-\d{1,2}$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}