// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([A-Z]{1}\d{2}[A-Z]{1}$|\d{1}\d{2}[A-Z]{1}$|\d{7}[A-Z]{1}$|\d{1,2}\-\d{1,2}$)").unwrap();
let string = "FPN 0085110A
FPN 0091010Y
FPN 0095100J
FPN 0095130B
FPN 0097660F
AGEBAND10YR 0-9
AGEBAND10YR 10-19
AGEBAND10YR 20-29
AGEBAND10YR 30-39
AGEBAND10YR 40-49
AGEBAND10YR 50-59
AGEBAND10YR 60-69
AGEBAND10YR 70-79
DRGGrpV6X 801A
DRGGrpV6X 801B
DRGGrpV6X A09B
DRGGrpV6X A11A
DRGGrpV6X A11B
DRGGrpV6X A12Z";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}