#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[\]|\[.+?\]|$"
Local $sString = "[]" & @CRLF & _
"[34143432]" & @CRLF & _
"dsadsad[343]43342dasdsad" & @CRLF & _
"dasdsada[]32eq3eq3[]ewaewq" & @CRLF & _
"qweqwe[342dsa]342423423343[]dsada" & @CRLF & _
"dasdsadsadsa[]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")