using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\]|\[.+?\]|$";
string input = @"[]
[34143432]
dsadsad[343]43342dasdsad
dasdsada[]32eq3eq3[]ewaewq
qweqwe[342dsa]342423423343[]dsada
dasdsadsadsa[]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}